Zophar's Message Domain

Go Back   Zophar's Message Domain > Emulation Talk > General Emulation

Reply
 
Thread Tools Display Modes
Old 08-28-2008, 11:50 AM   #1
the b man
Junior Member
 
Join Date: Aug 2008
Posts: 3
Default HELP! Mame++ is stuck in full screen gui mode...

Curiosity got the best of me and I selected the full screen option from the file menu for Mame Plus plus, and now the gui is completely stuck in this full screen mode, the only way I can exit the program now is to use the start key on my keyboard and manually close the program, or ctrl alt delete it away. And it has saved it like this so whenever I open the program it stays in full screen. I tried looking in the ini file and I dont see anything portaining to this. I have been trying for HOURS to find a shortcut key to bring the display back to normal, and have even been googling every possible way to say "stuck in mame plus plus gui" and cant find anything on this. Seriously, what the hell were the programmers thinking by not making a workaround for this?? I understand why the option is there, for ppl who want to hide windows for making an arcade cabinet, but what about when you want to use the program like normal? PLEASE, can someone help me get the program to run in a normal window again? The help would be greatly appreciated. Thanks.

EDIT: I wanted to also mention that all that ever comes up in google about this is about full screen mode for when playing the actual games, which is not what I need help with. Ive tried hitting the alt + enter and it does nothing in the gui itself. Just wanted to clear that up.

Last edited by Reaper man; 08-28-2008 at 02:47 PM. Reason: double post
the b man is offline   Reply With Quote
Old 08-28-2008, 03:58 PM   #2
Ugly Joe
Senior Member
 
Ugly Joe's Avatar
 
Join Date: Dec 2003
Posts: 1,461
Default

Have you tried deleting/renaming the ini file?
__________________
Ugly Joe is offline   Reply With Quote
Old 08-28-2008, 11:02 PM   #3
the b man
Junior Member
 
Join Date: Aug 2008
Posts: 3
Default

no I didnt try that, thought about it tho, but wasnt sure how the program would react. is it safe to just delete the file altogether? Will mame make a new one?

I was kind of hoping someone would have a definite solution for me, as this is something that seems pretty simple and I cant imagine there isnt a shortcut key to get the thing to run windowed. Seriously tho, if there isnt a solution for something like this then the programmers need to get to work, cus this is a rediculous bug...

if noone does know the solution to this, could someone give me a suggestion on a good emulation forum to post in and ask this question to? I dont know much about what forums are knowledgeable so if I could at least get some advice on that itd be great. Thanks.

Last edited by the b man; 08-28-2008 at 11:17 PM.
the b man is offline   Reply With Quote
Old 08-29-2008, 01:10 AM   #4
Ugly Joe
Senior Member
 
Ugly Joe's Avatar
 
Join Date: Dec 2003
Posts: 1,461
Default

Okay, just tried it out. The fullscreen shortcut key is F11. If that doesn't work for you, open up the mame32ui.ini file in the ini folder. Do a search for "full_screen" (without the quotes) and change the 1 to a 0.
__________________
Ugly Joe is offline   Reply With Quote
Old 08-29-2008, 03:33 AM   #5
the b man
Junior Member
 
Join Date: Aug 2008
Posts: 3
Default

i tried f11, didnt work. Im not using mame32, im using mame plus plus. The name of the .ini file isnt the same either. Ive looked thru the .ini file as well and there doesnt appear to be a full screen option anywhere in it. Ive even tried changing some of the values that I thought might be it to 0's and nothing works. And I did do this while the program was closed so it wouldnt just resave the full screen setting if I were to edit it while the program was open. So im kind of at a loss here... I guess the only thing left to do is to try and delete the .ini file. The program will make a new one right? I want to be sure.

Could this be a registry issue? Please, anyone that has experience with this program please respond. and Ugly Joe, can you please give me some recommendations of forums where there is heavy traffic so I could get a definite solution to this?

Last edited by the b man; 08-29-2008 at 03:35 AM.
the b man is offline   Reply With Quote
Old 08-29-2008, 03:34 AM   #6
Ugly Joe
Senior Member
 
Ugly Joe's Avatar
 
Join Date: Dec 2003
Posts: 1,461
Default

Just rename the .ini file, don't delete. The program won't be able to find it, so it should generate a new one. If it doesn't, you still have your old ini file as a backup.

Quote:
Originally Posted by the b man View Post
Could this be a registry issue? Please, anyone that has experience with this program please respond. and Ugly Joe, can you please give me some recommendations of forums where there is heavy traffic so I could get a definite solution to this?
If by "registry issue" you mean "the emulator is storing the config values in the registry", then maybe. I'm not sure what program you're even using, as any copy of MAME Plus Plus that I can find is built off of MAME32. If you're using some other build, what MAME source did you use as a base?

Also, I don't know of any other emulation forums to refer you to.
__________________

Last edited by Ugly Joe; 08-29-2008 at 03:57 AM.
Ugly Joe is offline   Reply With Quote
Old 09-07-2008, 02:03 AM   #7
klen11
Junior Member
 
Join Date: Sep 2008
Posts: 8
Default

Sometimes Re-Installing solves the problem. I know it solved it for me.
__________________
Huge Collection of Roms Located at http://google.com
klen11 is offline   Reply With Quote
Old 12-17-2017, 05:28 AM   #8
CDawg8888
Junior Member
 
Join Date: Dec 2017
Posts: 1
Default

I know that this is a really, really old reply and you probably already found a fix but if you haven't, this is what I did:

1. Right click MAME icon
2. Click properties
3. Go to the shortcut tab
4. Go to the drop-down box next to Run and select Minimized.
5. Click apply and then OK
6. Open up MAME again and it will minimize so click it again and it will open up in windowed mode.

7. Close MAME and go do steps 1-3 again and change the drop-down box to Normal Window (what it was at before you selected minimize)

Now every time when you open MAME, it should open in a window and not fullscreen.
CDawg8888 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:53 PM.

Contact Us - Zophar's Domain - Archive - Top

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.