Zophar's Message Domain

Go Back   Zophar's Message Domain > General Chat > Talk of the Town

Reply
 
Thread Tools Display Modes
Old 08-11-2008, 02:41 AM   #1
Rattlehead
Senior Member
 
Rattlehead's Avatar
 
Join Date: Jul 2008
Location: Hell...or Arkansas.
Posts: 292
Default Umm...oops!

Can someone help me out?

I had reinstalled a program, and for some reason the reinstalled program changed the file path, thereby rendering the program's shortcut in the start menu invalid. When I clicked it the "open with" box popped up. For some crazy-assed reason, the Vista programmers decided to make the "always use this program to open this type of file" box checked by default, unlike in XP. Well...I kinda forgot to uncheck it, and now every shortcut on my computer opens that program. I emailed Mircosucks tech support, and they told me to email the computer's manufacturer, which pissed me off. How do I undo this?

P.S.: I'm not gonna reinstall Windows, and the last restore point was about 3 months ago...so restore points aren't an option.
__________________
Killing is my business...and business is good!


Click here to level up my card!

Rattlehead is offline   Reply With Quote
Old 08-11-2008, 03:12 AM   #2
Reaper man
Member
 
Reaper man's Avatar
 
Join Date: Apr 2002
Location: Austin, TX
Posts: 5,409
Default

Quote:
Originally Posted by Rattlehead View Post
Can someone help me out?
I can try

the file extension for shortcuts is lnk

anyway, to change it's properties, you need to edit the registry (run regedit in the run window if you didn't know) Navigate to HKEY_CLASSES_ROOT\.lnk\

delete anything that has openwithprogids

actually, just screen cap what's in there and I could probably tell you what's wrong.
__________________
Reaper man is offline   Reply With Quote
Old 08-11-2008, 06:43 AM   #3
Xeon3D
Senior Member
 
Xeon3D's Avatar
 
Join Date: Feb 2004
Location: Albufeira, PT
Posts: 261
Default

click the file once, then shift-rightclick the link, there should be a "Open With" option, click it, then click "Choose Program" then tick the box "Always Open with This Program"

That should do it...
__________________

Those were the days...
Xeon3D is offline   Reply With Quote
Old 08-11-2008, 07:45 AM   #4
Rattlehead
Senior Member
 
Rattlehead's Avatar
 
Join Date: Jul 2008
Location: Hell...or Arkansas.
Posts: 292
Default

Quote:
Originally Posted by Xeon3D View Post
click the file once, then shift-rightclick the link, there should be a "Open With" option, click it, then click "Choose Program" then tick the box "Always Open with This Program"

That should do it...
No, because that's what I did. EVERY shortcut on my computer opens one program now, due to every shourtcut having the '.lnk' file extension. Whatever group of guys that programmed that into Vista are a bunch of fucknuts.
__________________
Killing is my business...and business is good!


Click here to level up my card!

Rattlehead is offline   Reply With Quote
Old 08-11-2008, 07:53 AM   #5
Rattlehead
Senior Member
 
Rattlehead's Avatar
 
Join Date: Jul 2008
Location: Hell...or Arkansas.
Posts: 292
Default

Here's the screenshot, reaper man.
Attached Thumbnails
Click image for larger version

Name:	fucked_up_lnk.jpg
Views:	162
Size:	94.4 KB
ID:	25  
__________________
Killing is my business...and business is good!


Click here to level up my card!

Rattlehead is offline   Reply With Quote
Old 08-11-2008, 12:41 PM   #6
Shadow
Senior Member
 
Join Date: Aug 2008
Location: Germany
Posts: 108
Default

Have you tried to reset the system to a date before your "accident" ? I think this should still be possible in vista.
Shadow is offline   Reply With Quote
Old 08-11-2008, 10:10 PM   #7
ToastyCheesy
Senior Member
 
ToastyCheesy's Avatar
 
Join Date: Apr 2007
Location: Port Orchard, WA
Posts: 234
Default

Quote:
Originally Posted by Rattlehead View Post
No, because that's what I did. EVERY shortcut on my computer opens one program now, due to every shourtcut having the '.lnk' file extension. Whatever group of guys that programmed that into Vista are a bunch of fucknuts.
ticking the box could mean checking it or unchecking it...

so if it's checked... ticking it will cause it to be unchecked
ToastyCheesy is offline   Reply With Quote
Old 08-12-2008, 02:21 AM   #8
Reaper man
Member
 
Reaper man's Avatar
 
Join Date: Apr 2002
Location: Austin, TX
Posts: 5,409
Default

Quote:
Originally Posted by Rattlehead View Post
Here's the screenshot, reaper man.
crud, that looks like the one on mine ;/
__________________
Reaper man is offline   Reply With Quote
Old 08-12-2008, 03:01 AM   #9
The 9th Sage
Senior Member
 
The 9th Sage's Avatar
 
Join Date: Mar 2004
Location: NY State in the US
Posts: 17,439
Default

On XP you could go to Tools-->Folder Options to mess with some of that stuff (ie get a list of extensions, icons representing them, and the programs associated with them). Isn't there some way to do this with Vista?

Then again, even with that I'm not sure what you'd set it to to fix the shortcuts. I wonder what'd happen if you deleted the entry in that window (Folder Options)?
__________________
Just can't wait to bomb some Dodongos.
---
http://www.xanga.com/zeldadd

Twitter
The 9th Sage is offline   Reply With Quote
Old 08-12-2008, 05:42 AM   #10
Umiliphus
Senior Member
 
Umiliphus's Avatar
 
Join Date: Jul 2006
Location: A shoe
Posts: 192
Default

Wow, that happened to me, once, maybe ten or more years ago. Of course I still used fake dos mode, the "run" menu and winfile.exe a lot at the time and plenty less programs in general because I didn't trust Windows 95 (because obviously I couldn't help breaking it). Those were some crazy, curmudgeonly times.
Umiliphus is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:13 PM.

Contact Us - Zophar's Domain - Archive - Top

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.