Zophar's Message Domain

Go Back   Zophar's Message Domain > Emulation Talk > General Emulation

Reply
 
Thread Tools Display Modes
Old 10-01-2008, 10:43 PM   #1
Stragg
Junior Member
 
Join Date: Oct 2008
Posts: 3
Default Wii/Snes9xGX SD support? please help

Running the homebrew channel on my wii and using it to load Snes9xGX. When the emulator first loads I get a message that reads.

---Preferences reset - check settings! Press A to continue

Once I hit the A button it leads me to the Preferences menu. I try to change then save my preferences and get a message that reads.

---Couldn't save fat://snes9x/saves/SNES9xGX.xml Pres A to continue

I gave up trying to change my preferences and tried to test out the games. Soon as I select Choose Game on the main menu I get a message that reads.

---Couldn't open fat://snes9x/roms Press A to continue

Once I press A to continue it allows me to search threw the directories to load a rom to play. /apps/snes9xGX/roms. All games I tried to run are flawless. Soon as I try any option of saving the game I get a message that reads.

---Couldn't save fat://snes9x/saves/Donkey Kong Country 1.srm Press A to continue (save game snapshot results in the same error but with a different file type that I cant read due to being off the edge of the screen)

SD card file layout (2gb wii sd card formatted to fat16)

/apps/snes9xGX
/saves
/cheats
/roms

I've searched for a couple days for some info on this without any luck. Seems the reading of my SD card works just fine. Anything that needs to write to my SD card fails. I read something about a gamecube memory stick being needed in slot B. Everytime I use the gamecube memory I can't load snes9xGX off the SD card. Soon as I pull out the gamecube memory snes9xGX loads right up. Can someone lend a hand and tell me what I'm doing wrong?
Stragg is offline   Reply With Quote
Old 10-02-2008, 03:19 AM   #2
The 9th Sage
Senior Member
 
The 9th Sage's Avatar
 
Join Date: Mar 2004
Location: NY State in the US
Posts: 17,439
Default

Quote:
Originally Posted by Stragg View Post
/apps/snes9xGX
/saves
/cheats
/roms
Ah ha. Your saves, cheats, and roms folders are in root? It should look like this....

/snes9x/saves/
/snes9x/roms/

and so on.
__________________
Just can't wait to bomb some Dodongos.
---
http://www.xanga.com/zeldadd

Twitter
The 9th Sage is offline   Reply With Quote
Old 10-02-2008, 01:14 PM   #3
Stragg
Junior Member
 
Join Date: Oct 2008
Posts: 3
Default

Thanks, works like a champ now.
Stragg is offline   Reply With Quote
Old 10-02-2008, 03:10 PM   #4
The 9th Sage
Senior Member
 
The 9th Sage's Avatar
 
Join Date: Mar 2004
Location: NY State in the US
Posts: 17,439
Default

Quote:
Originally Posted by Stragg View Post
Thanks, works like a champ now.
Hey, no problem.
__________________
Just can't wait to bomb some Dodongos.
---
http://www.xanga.com/zeldadd

Twitter
The 9th Sage is offline   Reply With Quote
Old 11-14-2008, 09:14 PM   #5
braids
Junior Member
 
Join Date: Nov 2008
Posts: 1
Default

i have the same problem as OP but when i look at my sd card there is no folder for saves or roms
braids is offline   Reply With Quote
Old 11-15-2008, 02:50 PM   #6
The 9th Sage
Senior Member
 
The 9th Sage's Avatar
 
Join Date: Mar 2004
Location: NY State in the US
Posts: 17,439
Default

Quote:
Originally Posted by braids View Post
i have the same problem as OP but when i look at my sd card there is no folder for saves or roms
Just make the folders on your SD card as described above and it should work. The program won't make the folders on it's own, so you have to make them.
__________________
Just can't wait to bomb some Dodongos.
---
http://www.xanga.com/zeldadd

Twitter
The 9th Sage is offline   Reply With Quote
Old 12-05-2008, 10:14 AM   #7
huskermanaz
Junior Member
 
Join Date: Dec 2008
Posts: 1
Default Wii emulator

Apparently this guy had the same problem as I. However, I have /apps/snes9x/roms .... /saves but i still get the error messages saying it couldn't load fat://apps/snes9x/roms/ and the same for the saves. Now the emulator I download was snes9xgx, and I tried changing the folder name to snes9x (was originally snes9xgx) which it is at now, but still get the error message. I get the same message for all my emulators. I formatted the card in fat, does it need to specifically be fat16? Isn't that the default? It is not a wii SD card, just a regular SD card, but i have seen other peoples work with regular SD cards too. I can play the games by going through the menu after the load fails like previous guy, but would be nice to save and load the way it should. let me know, mahalo! if you want i could include a snapshot of anything from my computer...

Huskermanaz

Edit
moved /roms /saves to ://snes9x/roms/ ://snes9x/saves/ and it is working like a champ. Note to self does not go through apps folder. Mahalo and happy hunting!

Last edited by huskermanaz; 12-05-2008 at 10:20 AM. Reason: i figured it out
huskermanaz is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:30 PM.

Contact Us - Zophar's Domain - Archive - Top

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.