Zophar's Message Domain

Go Back   Zophar's Message Domain > Emulation Talk > General Emulation

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 01-02-2009, 12:59 AM   #1
frozenspark
Junior Member
 
frozenspark's Avatar
 
Join Date: Dec 2008
Location: Philadelphia
Posts: 14
Default Trying to get PCSX2 to work.. please help

Yeah, it's me again.. asking for help as usual. I have PCSX2 version 0.9.4 and all of the plug-ins ready. I also have an ISO of Castlevania Lament of Innocence, which according to the official pcsx2 website has been tested and should work properly. When I load the game, everything works fine, however, when the actual game loads and I start playing the framerate drops from 60 to 20 and the game becomes unplayable. Once I reach some bad guys to fight I'm sure the frame rate is going to plunge even lower. What do you guys think is causing it to run so slow and is there anything I can do to fix it? My PC specs are as follows: Core 2 Duo 6420 at 2.12 Ghz, 2.00 GB RAM, Nvidia Geforce 8800 GTS at 640MB.. though I think my CPU is definitely a bottleneck.

In the case of my CPU being sucky, would updating it to this make the game run at normal 60 fps?:

http://www.newegg.com/Product/Produc...82E16819115037

Or is better to switch to Quadcore altogether (I'm not sure if PCSX2 is capable of taking advantage of all 4 chips at the same time)

Last edited by frozenspark; 01-02-2009 at 01:07 AM.
frozenspark is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:46 PM.

Contact Us - Zophar's Domain - Archive - Top

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.