Zophar's Message Domain

Go Back   Zophar's Message Domain > Emulation Talk > General Emulation

Reply
 
Thread Tools Display Modes
Old 09-15-2005, 06:20 PM   #21
hcs
Senior Member
 
hcs's Avatar
 
Join Date: Oct 2001
Location: California
Posts: 1,585
Default Re: Update

copied from my forum:
I think I've fixed that skipping problem. I finally experienced it myself while playing through some Mario Party 2 tracks, when it skipped now only a few USFs but an MP3 as well. This suggested that the problem lies in the track end message being sent more than once, as nothing else should be able to carry over from one plugin to another like that. Things are now set up so that even if the thread doesn't die right away when the stop message is sent to winamp (as can be the case sometimes) the message will only be sent once.
I was able to cause the skipping behavior by preventing the CPU thread from exiting cleanly, thus forcing it's eventual external shutdown, and this would cause it to skip many tracks. With the new track end code there is a pause while we wait for the CPU thread to die, and then a clean transition to the next track. I remember akane mentioning such a pause before skipping once, so I think I'm on the right track

Let me know, of course, if you experience this bug ever again.

http://www.halleyscometsoftware.com/usf/64thv100b10.zip64th Note v1.0 beta 10</a> <- be sure to use the new version now!<P ID="edit"><FONT class="small">Edited by hcs on 09/15/05 01:22 PM.</FONT></P>
hcs is offline   Reply With Quote
Old 09-16-2005, 08:36 PM   #22
Lillymon
Senior Member
 
Lillymon's Avatar
 
Join Date: Apr 2002
Location: England
Posts: 2,379
Default Re: 64th Note v1.0 (beta)

I've now got version 1.0 beta 10 working on foobar2000 thanks to the Wrapper for Winamp input, but it throws up an error whenever a track is played.

INFO (CORE) : opening file for playback :
INFO (CORE) : location: "file://C:\Nintendo 64\Nintendo 64 music\Super Mario 64\02 Super Mario 64 - Title Theme.miniusf" (0)
ERROR (foo_dsp_extra) : unable to resample from 32006Hz to 48000Hz
INFO (foo_out_dsound_ex) : Created stream: 32006Hz 16bps 2ch

It's only a minor thing since the tracks still play and sound fine, but I thought I'd let you know anyway in case there's something that can be done from your end.
__________________
Amelia Explains It All - Eventually. Probably.
Lillymon is offline   Reply With Quote
Old 09-16-2005, 10:19 PM   #23
Cornellius
Senior Member
 
Cornellius's Avatar
 
Join Date: Oct 2001
Location: Québec/Canada
Posts: 2,787
Default Re: 64th Note v1.0 (beta)

I had those, but I turned away the warnings. The tracks are playing fine and I've noticed no bugs. You're right still, it can be some usefull date for hcs.
__________________
My job

Industrial electronic technician
Industrial mechanic (Millwright)
Cornellius is offline   Reply With Quote
Old 09-17-2005, 12:59 AM   #24
hcs
Senior Member
 
hcs's Avatar
 
Join Date: Oct 2001
Location: California
Posts: 1,585
Default Re: 64th Note v1.0 (beta)

> I've now got version 1.0 beta 10 working on foobar2000
> thanks to the Wrapper for Winamp input, but it throws up an
> error whenever a track is played.
>...

That is an error with your dsp plugin, which apparently wants to resample things automatically to 48 KHz and doesn't like the odd frequencies 64th Note uses for exactness. If you select "round frequency" in the configuration this problem may, for the most part, be solved.

Also note that in the help dialog (accessible from the configuration window) it is stated that to ensure optimal compatibility with foobar2k and XMPlay select "round frequency" and "seek backwards".
hcs is offline   Reply With Quote
Old 09-17-2005, 05:17 PM   #25
Lillymon
Senior Member
 
Lillymon's Avatar
 
Join Date: Apr 2002
Location: England
Posts: 2,379
Default Re: 64th Note v1.0 (beta)

> That is an error with your dsp plugin, which apparently
> wants to resample things automatically to 48 KHz and doesn't
> like the odd frequencies 64th Note uses for exactness.

Yeah, I made it do that because I have a Sound Blaster Audigy and I prefer the best quality possible.

> If you select "round frequency" in the configuration this
> problem may, for the most part, be solved.

> Also note that in the help dialog (accessible from the
> configuration window) it is stated that to ensure optimal
> compatibility with foobar2k and XMPlay select "round
> frequency" and "seek backwards".

Well that seemed to fix all of the problems. I enabled both options and now foobar2000 seems perfectly happy. Thanks.

Edit: Well, it works for Super Mario 64 and OoT tracks. But Tetrisphere and Mario Kart 64 still don't like it. Is there any way I can just get foobar2000 to shut up?<P ID="edit"><FONT class="small">Edited by Lillymon on 09/17/05 03:06 PM.</FONT></P>
__________________
Amelia Explains It All - Eventually. Probably.
Lillymon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:44 AM.

Contact Us - Zophar's Domain - Archive - Top

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.