Zophar's Message Domain

Go Back   Zophar's Message Domain > Emulation Talk > General Emulation

Reply
 
Thread Tools Display Modes
Old 01-06-2006, 12:18 PM   #1
Lobster Cowboy
Senior Member
 
Join Date: Oct 2002
Posts: 2,836
Default Hey Mac users! Is MacMAME goddamn slow on your computer, too?

I have a 1.8 Ghz G5 at work, and my old 1.1 Ghz home PC ver. of MAME absolutely destroys MacMAME in performance. I mean, MacMAME can't even run old games like Darius or Gauntlet at full speed.

Any other OS X users try MacMAME, and if so, can you get it to run faster? Am I doing something wrong, or does MacMAME just blow ass? As I said, my work computer (and this computer has no weird logging/firewall/anything protection, and has nothing out of the ordinary) is a 1.8 Ghz G5, 1.5 gigs of RAM, at least a Radeon 9200, and OS X 10.3.9 Panther.

Any ideas?

*edit* BTW, I'm using the most up to date ver. of MacMAME, .103
<P ID="signature">
</P><P ID="edit"><FONT class="small">Edited by Lobster Cowboy on 01/06/06 10:23 AM.</FONT></P>
Lobster Cowboy is offline   Reply With Quote
Old 01-06-2006, 11:05 PM   #2
packardmelan
Senior Member
 
packardmelan's Avatar
 
Join Date: Aug 2002
Location: Louisville, KY
Posts: 707
Default Re: Hey Mac users! Is MacMAME goddamn slow on your computer, too?

A lot of emulators on the Mac were ported by one guy from emulation.net -- and requires his pay-for "Emulation Enhancer" to get full speed, higher resolutions, filters, and stuff. Now to be completely honest, I'm not sure if MacMAME is guilty of it.

Have you tried AdvanceMAME? Once upon a time there was a source port to OSX, but I think you have to compile it yourself.

Also, from the MacMAME page:
Q. Can I make it run faster?
A. There are a few things you can do to speed it up. Try the following.

* Make sure you check "Full Screen" in the video tab.
* Make sure "Ignore other applications" is checked in the "Game" tab.
* Turn off Appletalk and disconnect from the internet.
* Make sure "Generate debug log" is unchecked in the "Info" tab.
* Increase the frameskip to 1, 2 or 3 (via the Options menu)
* Run the game in actual size
* Turn the sound quality down to 11025 Hz
* Disable FM sound
* Disable sound
* Uncheck "anti-alias vectors" for the vector games
* Switch your screen resolution to 800x600 or higher so the entire game fits on the screen
<P ID="signature">http://www.sloganizer.net/en/</a></P>
__________________
...a man's reach should exceed his grasp, or what's a heaven for? -- Robert Browning
packardmelan is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:18 PM.

Contact Us - Zophar's Domain - Archive - Top

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.