Zophar's Message Domain

Go Back   Zophar's Message Domain > Emulation Talk > General Emulation

Thread Tools Display Modes
Old 06-24-2014, 06:45 AM   #1
Junior Member
Join Date: Jun 2014
Posts: 2
Default Final Fantasy II Famicom on IMBNES

I've recently tried to play FFIIj on a PSX with IMBNES and I've been having trouble and I wondered if this was a common problem. I looked all over the internet and I can't find any info.

I've had this particular version for like a decade, the Neo Demiforce translation. It works fine on PC but IMBNES messes up in battles. The menus get all glitchy when monsters attack or you move the cursor.

I tried the Parasyte patch and that fixed the title screen problem, but battles are still messed up. Is it my version of the game or is it IMBNES? FFI and FFIII have both been fully played through and work fine. Thanks for the help!
Lanterpost is offline   Reply With Quote
Old 12-26-2015, 06:06 PM   #2
Junior Member
Join Date: Dec 2015
Location: Brazil
Posts: 8

The problem is with imbnes. I, too, have this problem. But you can still, play FF Origins
Danick is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 02:38 PM.

Contact Us - Zophar's Domain - Archive - Top

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.