View Single Post
Old 03-19-2008, 01:25 AM   #4
Essee
Regular Member
 
Join Date: May 2007
Posts: 45
Default Re: Zophar's ROM Archive

> Um, since when has this been there, and on a subdomain no
> less? I was just wondering, since I had no idea it existed
> until I stumbled onto it just now.

I stumbled upon it a few days ago, and started passing my "WTF" to a couple other people I talk to from these boards (which, for all I know, may be how you found out about it?). Yeah, it's weird... According to the first post by the admin of that section on those forums, it's been there since January 8th of this year. I don't get it... it's always been a site rule, even before I really knew what this site was (years ago), that you don't even ASK about ROMs. I wonder who apparently gave the guy the subdomain; it looks like the guy only got permission recently, from what he said in http://roms.zophar.net/forums/showpo...35&postcount=7an early post</a>, so I'm thinking this either didn't exist before or didn't exist for a long period of time just prior to this.

Still, it's weird, and apparently has terrible download speed, although it has "772 GB" of ROMs. And it seems like they ARE hosted on here, or at the very least they're not just linking to Megaupload or Rapidshare or anything like that. <img src=smilies/headshake.gif>

It's also kinda ironic (or at least sad) that THIS board seems to be having troubles when that board has just started up.
<P ID="signature"></P><P ID="edit"><FONT class="small">Edited by Essee on 03/18/08 09:28 PM.</FONT></P>
Essee is offline   Reply With Quote