View Single Post
Old 08-10-2015, 01:49 PM   #6
InVerse
Senior Member
 
Join Date: Jul 2002
Posts: 1,489
Default

Quote:
Originally Posted by humbugacclaimed View Post
I hate to say this but your iPod is completely outdated and if in case it turns on you can not upgrade it because new updates is not compatible with its os.
Why would you need to update it? The MP3 format hasn't been changed since long before the iPod even existed. A first generation iPod plays MP3s just as well as a current generation iPod.

Hell, my 128MB Creative Nomad MuVo from 2002 still works, as I found out yesterday.
InVerse is offline   Reply With Quote