View Single Post
Old 12-10-2010, 08:15 PM   #24
Reaper man
Member
 
Reaper man's Avatar
 
Join Date: Apr 2002
Location: Austin, TX
Posts: 5,409
Default

Alright, so when YouTube user KirbytPink became my 100th Subscriber (thanks to my exposure over at GoNintendo), I asked him what my next rom corruption video should be. He chose Kirby's Adventure, even though I told him that I was planning on doing that game soon and that he could chose something else. He insisted that I do it next, so that's what I did.

Kirby's adventure more than likely needs no introduction. Released near the end of the NES's lifecycle, it is considered by many to be one of the best NES games ever released. You control Kirby, a cute little round guy (thing?) that can copy enemy's powers by eating them. Your task is to retrieve the 7 star rod pieces from the various bosses in the game. My task is to corrupt the game beyond repair.

When I did it though I had plans to do my corruptions a bit differently from now on:

1. I no longer use my computer's random number generator anymore to corrupt the games. I now use the true random number generator from random.org using an awesome python library I found, so yes, my corruptions are going to be truly random going forward (with the exception of Dr. Mario, Duck Hunt, Duck Tales, and Excitebike as those corruptions have already been made).
2. I hated how premiere scaled video, so I'm doing all the scaling in virtualdub (I also found out that cropping applies a needless filter unless you selected nearest neighbor, so that was fixed as well)

Anyway, I recode my script and start to corrupting, when I find that I'm getting horrible results. Turns out that Kirby is a VERY large game, and I was corrupting around 256 bytes! I wasn't able to even get to the first level without crashing! Eventually I had to realize that I needed to cut my bytes in half in order to get anything good, which I didn't want to do. I did anyway, and the 128 byte corruptions worked a lot better.

Anyway, once that was completed I started to record and lo and behold, Nestopia decided to shit itself when recorded, like it has for 2 of my previous videos, due to a nasty movie recording bug. So once again, I had to rely on FCEUX (which I loathe) for recording. Of course, certain iterations worked differently, which was upsetting, but I pressed on, recording away. It isn't as entertaining as when they were running on Nestopia, but it was good enough I guess.

Then came the planned resizing in virtualdub. That's when I noticed the video had a weird filter on it already. I don't know if it was the fault of FCEUX, or ffdshow or what, but it was disturbing to see that on what was supposed to be lossless. I already had everything recorded, so I decided to just go with it. Then I noticed that the video was 60.1FPS instead of 60. The developers told me that the NES outputted at that rate, but I somewhat had my doubts about it, and I'd much rather have it recorded at 60, but whatever, I continued anyway.

Then came putting it all together in premiere. Everything was going relatively smoothly until it came time to export. Since I was working with bigger videos due to the resizing, it decided that it needed 7 BLOODY HOURS to encode. Needless to say I have had enough of premiere, and will probably be moving on to something that isn't as retardedly slow. I'll keep you guys posted on that.

After re-encoding back to H.264 lossless I am left with a VERY slow upload ever since my friend/neighbor has gimped his cable connection to shit speeds, so it's another 7 hours to upload the damn thing. Needless to say, this video has left me mentally drained and frustrated. Sorry about the really long rant, I just needed to vent. I'll probably take a quick week off to start learning another video editor, etc and to run some video tests.

Until then, I'd like to announce that I'll be picking a random subscriber out of every 100 subscribers for requests. The next "request" subscriber is going to be really soon, so please be sure to subscribe for a chance to pick my next game!

anyway *cough* here's the vid:


__________________
Reaper man is offline   Reply With Quote