View Single Post
Old 08-11-2010, 12:30 AM   #1
scarecrow
Junior Member
 
scarecrow's Avatar
 
Join Date: Aug 2010
Location: Texas
Posts: 13
Default

Hello, Zophar's Domain, I've been watching you.

Well, more like Lurking for the past few weeks. I didn't want to post without searching extensively first (Plus I like trying to figure it out myself).

I've been trying to HexEdit Mario Kart 64 recently, well, it's the only thing I've actually tried, but more on that later.

Anyways, for some reason, Hexecute has decided to bug out on me. When I'm using search and I search for a string (text or hex) that doesn't appear in the file, all the characters are replaced with incorrect ones. I know it's the wrong characters, because at the beginning of the code are the words "MARIOKART64". When I go back to look at this after searching, not only is the text replaced with "$........" but the hex code has changed as well.
Any ideas?

And on a side note:
I discovered this while trying to search for "318c". I noticed a pattern of it appearing over and over again, so I was trying to catalog when the sequence began, and when it ended, so that I could corrupt that specific area for the string "318c" in an attempt to figure out it's function in Mario Kart's code. Hexecute is supposed to be able to search for up to 16 characters, so I typed "318c" in the search, but then the glitch I described above happened. I can search fine for just "31" and "8c", but how would I search for four characters simultaneously?

I apologize for the double post, I really do, I hate double posters. ><*
The Edit function isn't working on my first post for some reason, so this is all I can do.

I figured out that it also glitches when you search for letters in hex as well, which is odd.
It also glitches just randomly while it's running as well.


----------EDIT--------------

I need to run it in Compatibility mode for Windows XP to fix searching for characters in sets of two, but it still glitches when I search for characters in sets of 4.


---------EDIT---------------

And now it stopped working when I run it in compatibility mode.

---------EDIT---------------

Ok, so now I've figured this out:
-Run in Compatibility Mode for Windows XP (Service Pack 2)
-Run as Admin
-Check the bottom three boxes in settings.

It will search for most letters in hex and not glitch, even in sets of four(except ffff), but when I search for something invalid it still glitches.

--------EDIT----------

Screw it.
I got off my ass and got Hex Workshop.
__________________
"Do it, for teh lulz." ~ Proverb

Want custom made, realistic, real-life props? Check out my site.

Last edited by Reaper man; 08-11-2010 at 07:00 AM. Reason: fixed
scarecrow is offline   Reply With Quote