View Single Post
Old 06-07-2007, 12:15 AM   #14
Essee
Regular Member
 
Join Date: May 2007
Posts: 45
Default Re: VBA Sound Trouble

> Whoops, sorry Essee. I didn't check your profile. I kind
> of hate guys treating women like shitheads because they are
> female and did that out of a gut reaction. Enjoy the forum
> while your here since it was obviously a joke you were
> making and I was the idiot in this case even though I meant well.

Haha, hey, I don't really mind... I'm already aware that I sound pretty gender-neutral when I post online, and hey, I'm all for gender equality. =P I definitely didn't mean to offend anyone who shares my gender, especially if they know their computer intimately, at any rate, and if I would've justified that response if I were a guy, I probably should have worded it better anyway! I think I might stick around this place for a while, anyway, since I don't really post on any other forums (assuming DeviantART isn't counted as a forum, and I've been M.I.A. there lately) at the moment, and honestly you all (from what I've seen thus far) seem like a fairly cool group. Not sure how often I'll be posting 'cause I'm going to have a fairly busy summer, but we'll see!

>VBA doesn't allow you change the buffer size, apparently. One
>thing you may want to try is applying "Use Old Synchronization"
>for the sound engine.

Unfortunately, I already gave that a shot-- the first place I screwed around was all the sound settings. You DID remind me of something I thought I might not have tried-- unchecking Synchronize in the regular emulator options-- but that didn't do the trick either. Maybe I'm just cursed!

>The best option would be to go into process manager and ser the
>priority thread to high normal and se if that helps. If it
>doesn't then it might be an issue with the program or something
>hardware related. Also, a posting of PC specs would be nice...

I tried through VBA's built-in priority-setter on all settings other than normal, didn't do anything. As for the process manager, Above Normal and High didn't seem to do anything either. I don't think there's a process (although conceivably it could be a service because I don't check those 24/7) messing with me, because I recognize them and none of them have been changed in several months. Also, other emulators that I know have higher requirements-- I have ePSXe on here and have played a couple of my games that wouldn't require an analog stick on it (since I don't have a controller with one)-- run just fine.
But, for reference, I essentially have running at any time (besides the default XP processes): TeaTimer (Spybot: Search & Destroy's tool for letting you allow/deny startup and registry changes), AVG Free 7's Resident Shield (my antivirus software), and my tablet software. I also sometimes have Firefox, iTunes, or SeaMonkey (excellent browser that is also from Mozilla) running. I've tried killing every process except VBA in order to diagnose that-- no luck. =/

As for my specs, oookay, here are roughly my specs (let me know if there's some reason you need more specs, 'cause I don't know if there's a particular "code" as far as posting them goes, and I'm just finding the info through myself quickly and Dxdiag):
Windows XP Pro SP2 (up-to-date)
AMD Athlon 64 Processor 3700+
2.41 GHz CPU
512 MB of RAM
NVIDIA GeForce 6200 A-LE, 128 MB memory
SoundBlaster PCI512 sound card (16-bit, I think... hasn't given me any trouble in the couple years I've had it)
Running DirectX 9.0c
Main HDD: 80 GB (37.6 free), Secondary: 40 GB (21.7 free)
Desktop Resolution: 1024x768

Also, AS I KEEP FORGETTING TO MENTION, I'm playing VBA windowed at 2x scale. Not a fan of running most stuff fullscreen, myself. I usually use the hq2x filter built-in, but I've tried not using a filter (and/or using other filters) with no luck.

Before I posted this, I ran another virus and spy/adware scan (using Ad-Aware, Spybot: S&D, AVG Free, HijackThis) where nothing popped up, effectively reinstalled VBA by replacing VisualBoyAdvance.exe...
I then, on a whim, tried dropping my render method to Direct3D, nothing. BUT when I dropped down to DirectDraw... it finally stopped. This looks (to me) pretty bad, because the refresh rate of the window seems to drop. Adding VSync made the problem reappear, but I have had it off since I tried testing whether VSync was the problem. For no apparent reason, when I tried switching back UP to Direct3D (no VSync), it remained fixed! Switching back up to OpenGL... broke it again. D3D still doesn't look as good as OpenGL, but I can stomach it if need be. I assume that I never found this out because, while I did switch down to D3D, I did not try it again after switching to DD.
What I want to know at this point is... Why is it that running it in OpenGL suddenly does not work perfectly, and why can I actually run other programs in OpenGL <u>2</u> with no problems? From my stats, my machine should be able to handle it with no problem (as it HAS been until now), right? So annoying! If nobody has any other ideas, I'll stick with this configuration, but at any rate thanks for all the suggestions-- at least the VSync one WAS part of the problem. Also... sorry for the insanely long post. <<
<P ID="signature"></P>
Essee is offline   Reply With Quote