View Single Post
Old 05-26-2007, 09:12 AM   #1
Regular Member
Join Date: May 2007
Posts: 45
Default VBA Sound Trouble

I have been using Visual Boy Advance 1.7.2 for a long time, and it has worked beautifully in all respects (zero slowdown, perfect emulation of graphics and sound)-- until a week or two ago. So! Originally the sound was working perfectly. Even though I made NO software setting or hardware changes between when I had no problems and now, I have started getting fuzzy sound for periods of about 1-3 seconds. I think the period between fuzzings is usually about 15 seconds, but it varies a bit. The emulation speed shown also seems to drop from 99/100% to 96 AFTER it happens each time, although there doesn't seem to be a change in the speed of the gameplay itself. The game I'm playing has no effect; games that used to play fine months or even a week before this started happening all have this problem now. None of the other programs on my computer, even other emulators, are having this problem in the least, either, so I think something is now going wrong within my emulator.

I have already tried playing with several settings in an attempt to get this to work (mostly in the sound settings, although I did turn off my chosen graphics filter at least once), but no success. I scanned my computer (even though I was sure there wouldn't be anything to find) and I don't have some random virus/spyware/adware that ONLY targets VBA. Being an audiophile (and frequently choosing my games FOR their music/sound), this is becoming VERY frustrating for me. I would try redownloading the emulator except A) I am on dial-up, and more importantly B) I don't want to risk accidentally losing any of my saves, because I recall I attempted to move ZSNES to a different directory once, with all my saves in that folder, and when I started a game that is VERY difficult to restore progress from, even savestates, it had overwritten my original save with a blank one as if it couldn't see the save file I had. I'd prefer not to take my chances again.

Does anyone have any clues as to the problem, or advice on how to fix it, short of a reinstall? I can post my specs if anyone wants, but since they have not changed between the time it was working and now, I don't think those will help. Thanks in advance!
<P ID="signature"></P>
Essee is offline   Reply With Quote