Zophar's Message Domain

Zophar's Message Domain (http://www.zophar.net/forums/index.php)
-   General Emulation (http://www.zophar.net/forums/forumdisplay.php?f=5)
-   -   Flying Warriors - NES - Controller glitch? (http://www.zophar.net/forums/showthread.php?t=15041)

(wraith_) 08-16-2011 07:16 PM

Flying Warriors - NES - Controller glitch?
Just curious, does anyone know of any known emulation bugs with the controls for Flying Warriors for NES?

I'm running Vista x64 with DirectX 11. I've tried a few emulators (FCEUX, Nestopia and Nintendulator) two different controllers using Direct Input (a Sidewinder USB 1.0 and a Logitec Dual Action) AND a keyboard. All three emulators and both controllers exhibit the issues.

There's a lot of trouble doing anything that requires several buttons be pushed, most notably if one of the buttons is the up or down button. This is a very primitive fighting game, so being able to press multiple buttons is key. ;)

I'm wondering if the issue is the game itself... maybe it knows it's being emulated, or maybe the controls are just poorly coded. I feel like I plated this game successfully only an emulator years ago, and wonder if the issue is the "more accurate" emulation on current emulators.

D-- 08-18-2011 12:03 AM

Have you tried using a USB game pad to play?

It's possible that your keyboard, if connected to a USB port, is maxing out how many key presses it can send at once.

You might want to try connecting it to a USB->PS/2 adapter if you really want to play with the keyboard.

(wraith_) 08-18-2011 01:57 AM

I've got the keyboard on USB, and the controllers were as well. The Sidewinder is a million years old, but plays other games quite alright.

I did try an older "less accurate" emulator, NnnesterJ plays the game without control issues and that was the end of my testing. I'm going to chalk it up to the resource requirements on these new-fangled emulators, though resource requirementss on NES emulation shouldn't be an issue when you're running an Intel 2.2 ghz Quad Core ;)

D-- 08-18-2011 05:50 AM

You would be surprised what they are gobbling up these days. I just had a nightmare of a time getting NES emulation working on my HTPC under mednafen. I thought for sure a 1.91GHz dual-core 64-bit Atom would be enough to manage playing it without tearing. I mean, it worked fine four years ago.


Turned out I had software bilinear interpolation on (it's on by default). It decimated performance. I switched it off and chose a modest GL shader to handle it instead. After that, everything was fine.

Accuracy does matter especially in older systems and it's great things are moving in that direction. Thankfully, the old stuff is still hanging on for all those times speed when performance an issue.

All times are GMT. The time now is 03:08 AM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.