Zophar's Message Domain

Zophar's Message Domain (http://www.zophar.net/forums/index.php)
-   General Emulation (http://www.zophar.net/forums/forumdisplay.php?f=5)
-   -   Genesis Emulators and full screen issue on Windows 10. Help (http://www.zophar.net/forums/showthread.php?t=17794)

Lassic 08-28-2015 08:19 PM

Genesis Emulators and full screen issue on Windows 10. Help

I can't get proper full screen gameplay with genesis emulators on windows 10 x64.

Whenever i press alt tab, the screen will stretch to fit my widescreen monitor, and will never maintain the 4:3 format, no matter what option i set on configurations.

In fact this is not the main problem. My major concern is that the image, once on full screen, is zoomed! I can't get to see the whole picture.

I can get perfect gameplay on windowed mode, but this is not what i am looking for.

I already tested the latest versions of the following emulators:

Kega Fusion (3.64)
Gens32 (2.14)
Gens32Surreal (1.9 std)
Regen (0.97)

Like i said, i tried different configurations, but none of them worked for me.

My VGA is Radeon HD 7750. I am using the latest drivers. Windows 10 x64 pro with all the updates.

Other emulators like Higan, Dolphin, Demul and Mupen 64 Plus work flawlessly (had problems going full screen with N64, but i already fixed it).

It seems that these emulators are completely abandoned, which is somewhat sad.

Does anyone else have this problem as well? What i can do to get proper genesis emulation on my OS? Any alternatives?

Some of these emulators don't have an official forum anymore or they are abandoned as well.


Lassic 08-28-2015 08:52 PM

Well, i just tested the Exodus emulator and now i can play at full screen without any image distortion or zooming. Great.

I didn't like very much this Exodus emulator, though. If anyone find a solution to get proper full screen on w10 with one of the other emulators, please, let me know.

InVerse 08-28-2015 09:49 PM

I just tested out Kega Fusion 3.64 in Windows 10 and it worked just fine without requiring any tweaks. My video card isn't anything special, just a Nvidia GeForce GT 440.

The only thing I could suggest is hitting Alt-9 once or twice to make sure you don't have the zoom feature enabled.

Lassic 08-28-2015 10:04 PM

Last time i used Kega, i got an error message when trying to go full screen. And when i finally made it, i had the same problem with the zoom.

Now i tried to go full screen with Kega again to test your tip and i can't make it. I am getting the same error message: directDraw Init Error: #2 - Unable to set Display Mode"

Lassic 08-28-2015 10:31 PM

I realized what was the problem with the zooming on full screen.

I had changed the DPI Scaling Size on my windows from the default 100% to 130%.

I did this because i find it's too hard to read the small characters on the screen on my 20in monitor with its 1600 x 900 pixels.

So, everytime i tried to go full screen with one of these emulators, the image become 30% bigger than it should.

I also noticed i can actually get 4:3 format on full screen as well. Maybe i was mistaken thinking the image was stretched because of the zooming.

Back to the DPI, this is quite annoying because i can't go back to the default 100%, and i would have to change it everytime i decide to load a genesis game on my computer.

Other emulators, including the Exodus one don't have such a problem. The DPI scaling is a feature that Microsoft included on Windows 8 for the first time, i think. With windows 10, they decided to maintain it. Since all these emulators were developed during the windows XP/7 age, such problem could not be foreseen, i guess.

I still can't figure it out the error message on Kega. I just remember that i get this error since i installed windows 8, three years ago. Now with the windows 10, the problem persists.

Lassic 08-29-2015 02:30 PM

So i finally fixed the issue with the zooming and the stretched image.

I changed something on my AMD Catalyst Control Center (let the GPU handle the scaling + keep proportion).

I also found a new way on windows 10 to make the texts and icons larger, although i can only choose between 125% and 150%.

Doing all these things fixed the issue for me.

I still can't go full screen with Kega, but i am fine with it.

InVerse 08-29-2015 03:05 PM

Like I said, Kega was working perfectly fine for me. It sounds like the problem is with your setup. If you can't see your own screen, you need to invest in a bigger monitor. Check Good Will, I've donated >20" monitors to them in the past and they usually sell them for $5-$10.

But if you installed Windows 10 expecting good emulation support, you're barking up the wrong tree. First of all, Genesis emulation is dead. The only people who care about Windows 10 development are the people looking to cash in on the ability to easily port between Windows 10 & Android. If you're willing to pay someone to update an emulator to have Windows 10 support, then you might be able to get what you're looking for, but otherwise I would suggest running Windows XP in a Virtual Machine if you're going to insist on using retro software on a next gen platform.

Lassic 08-30-2015 05:04 AM

Well, i fixed the problem with Kega by deleting the fusion.ini file. Now it's just perfect.
I am not an avid genesis gamer, i just tried to load one game the other to play with my friend and realized there was a problem. It's been years since the last time i tried to play on a genesis emulator, so it's good to know that they still works on modern machines. There aren't much to improve with these emulators i guess, that may explain the lack of updates on windows OS.

gun.rugger 04-04-2016 02:36 AM

I apologize for bumping a necro-thread, but I also found a solution for this. Running the emulator in compatibility mode. I am on windows 10 and ran it in compatibility for windows 7.

Setting screenshot: http://imgur.com/ukT1cLU.png

Thank you InVerse. I wouldn't have figured it out if you hadn't said "But if you installed Windows 10 expecting good emulation support, you're barking up the wrong tree."

JordanjS 07-23-2016 06:40 PM

Big thanks for that tip, gun.rugger. Now I can finally play Lunar!

All times are GMT. The time now is 03:28 PM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.